Hi, devs.
How would you name a special "empty" store class used when some store
feature is disabled? (see FakeAttachmentVersioningStore, XWIKI-2275)
1 Void
2 Empty
3 Disabled
4 Dummy
5 Mock
6 else?
Vincent Massol wrote:
I'm not sure if "Fake" is the best word
to use...
I don't think it's a Fake one. It's an empty implementation that does
nothing. so I'd rather call it: VoidAttachmentVersioningStore or
EmptyAttachmentVersioningStore.
Also I'd replace the comment like:
+ public void deleteArchive(XWikiAttachment
attachment,
XWikiContext context,
+ boolean transaction) throws XWikiException
+ {
+ // not needed
+ }
with:
"// Don't do anything since it's a void implementation."
WDYT?
Ok. I'll replace.
--
Artem Melentyev