Hi devs,
As I mentioned already I'm modifying all APIs in XWikiDocument to use References
(I'm adding new APIs and deprecating old ones).
While doing this I'm also fixing names for new APIs. So far I'm modifying 3
things:
- replace Vector by List
- replace Object by XObject in API. For example: getxWikiObjects() --> getXObjects(),
getObjects(String classname) --> getXObjects(DocumentReference classnameReference)
- replace Class by XClass in API. For example: getxWikiClasses --> getXClasses()
Note1: I wanted to use getObject and getClass but getClass is reserved already.
Note2: in the new model we won't have this problem since we'll intelligently use
another name for object definitions, something like ObjectDefinition :). We could also
change Object but it's less problematic and it's probably ok to keep it.
Here's my +1
Thanks
-Vincent