Hi,
2008/1/13, rssh <rssh(a)gradsoft.com.ua>ua>:
Good day, community.
I think, some parts of JIRA comments (see below, especially after '***') must
be discussed in mail list.
---------- Forwarded Message -----------
From: "rssh" <rssh(a)gradsoft.com.ua>
To: "Thomas Mortagne (JIRA)" <jira(a)xwiki.org>
Sent: Sun, 13 Jan 2008 18:45:56 +0300
Subject: Re: [Issue] Commented: (XWIKI-2006) allows to configurate name of
database schema [patch[
your code does not follow the xwiki coding rules
to be applied
(mainly javadoc and some code style). See
http://dev.xwiki.org/xwiki/bin/view/Community/CodeStyle
Hmm, on first intention coding rules are standard. Ok, I will look and
produse third patch.
***
Some more personal comments:
- I think you should separate theses two different features in two
jira and patches - I don't see the need for staticParam(String key)
and staticGetMainDatabaseSchemaName()
Ok -- what is another way to read something from configuration file in
static context ?
Is name of configuration file is not encapsulated inside XWiki ?
- I think only HibernateStore
should knows about main database name and prefix
database name,
especially the way you implement it at wiki name -> database name
conversion.
This means remove all you add to XWiki and call
context.getWiki().Param("xwiki.db")
directly in
getSchemaFromWikiName for example. - I think "xwiki.db" is not the
during initialization of wiki (where exists calls of hibernate store)
context.getWiki() return null, so this is impossible.
It should not be. When exactly do you have context.getWiki() null ?
Maybe there is a problem in a particular case. I tested xwiki
initialization and, in getSchemaFromWikiName, context's wiki is never
null even the first time it's called in virtual or non virtual mode.
best name for that parameter as it's only
used in virtual mode and
it's the main wiki database name I would prefer something like
"xwiki.virtual.db.main". If this parameter means also the database
name in non virtual mode I doubt it works as context's database is
not taken into account in non virtual mode.
I would vote against usage of 'xwiki.virtual.db.main' in non-virtual mode,
because find this confusing.
(But you free to change names during/after import of the path)
You did not read all all I said : "If this parameter means also the
database name in non virtual mode I doubt it works as context's
database is not taken into account in non virtual mode." What I said
is than if it works only in virtual mode I would prefer a more clear
name than wiki.db and the way you did I don't see how it could work in
non virtual mode. In fact it could make error with oracle databases I
think because it will use the configured name for update schema and
hibernate.cfg one for store and load.
About your implementation of main wiki name, I
would prefer to
Sorry, I can't understand you. I does not touch implementation of main wiki
name.
modify what XWikiContext.getMainWiki returns
which is here for
that. We could remove derby and hsqldb specifics conversions that
A afraid, that if I understand what you try to say, this will be completely
other story. Much bigger and harder (and I afraid in some cases impossible).
Why -- because in XWiki getDatabase()/setDatabase() calls used in meaning
get/set database and get/set application name. Now, when database name and
wiki name become differ, to do this would be necessary review each call of
get/set Database() in XWiki and XWikiContext, understand - what was means
(application name or database name) and change. This would be more complex
structure (where we will have logical database names) and (from my point of
view) this complexity will not give any benefits.
would be useless if it can be setted in
xwiki.cfg. This means review
the code to remove the remaining "xwiki" use as main wiki in place
of calling context.getMainXWiki().
Sorry, but you talk about some other path. I just does not touch this
part of xwiki, in my path all about 'logical names' is remaining as in
previous version.
allows to
configurate name of database schema [patch[
-----------------------------------------------------
Key: XWIKI-2006
URL:
http://jira.xwiki.org/jira/browse/XWIKI-2006
Project: XWiki Platform
Issue Type: New Feature
Affects Versions: Future
Environment: any
Reporter: Ruslan Shevchenko
Priority: Minor
Attachments: configurated_db_schema_02.patch
attached path allows to configure
1. name of database schema of main wiki.
2. prefixes for database schemas for virtual wikis.
(tested by hand with normal and virtual wiki configurations)
--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the
administrators:
http://jira.xwiki.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
http://www.atlassian.com/software/jira
--
Ruslan Shevchenko
GradSoft.
http://www.gradsoft.ua
------- End of Forwarded Message -------
--
Ruslan Shevchenko
GradSoft.
http://www.gradsoft.ua
_______________________________________________
devs mailing list
devs(a)xwiki.org
http://lists.xwiki.org/mailman/listinfo/devs
--
Thomas Mortagne