-0, the fact that you have to click on a button/link in order to login
is an implementation detail IMO. The page object (ViewPage) should hide
this. It may be fine for "click", but I wouldn't like to change the name
of a page object method (an API) whenever the underlying user
interface/interaction changes.
Thanks,
Marius
On 06/24/2011 10:51 AM, Vincent Massol wrote:
Hi,
The proposal is to make all click methods be named click*() in UI functional tests.
For example in ViewPage, instead of:
public LoginPage login()
{
this.loginLink.click();
return new LoginPage();
}
We would have:
public LoginPage clickLogin()
{
this.loginLink.click();
return new LoginPage();
}
Right now we have some methods starting with click and other not following this pattern,
the idea is to homogeneize it.
WDYT?
Thanks
-Vincent
_______________________________________________
devs mailing list
devs(a)xwiki.org
http://lists.xwiki.org/mailman/listinfo/devs