On Feb 12, 2013, at 2:24 PM, Sergiu Dumitriu <sergiu(a)xwiki.com> wrote:
On 02/12/2013 06:03 AM, Vincent Massol wrote:
> Hi,
>
> I'd like to propose to use the following naming conventions for the extensions
from commons/rendering/platform that are exposed on e.x.o:
>
> - "API" suffix for api modules. e.g. "Text API" , "Velocity
API" instead of currently "Text Module", "Velocity Module", etc
> - "Application" suffix for ui modules, e.g. "Wiki Manager
Application", "Logging Application", "IRC Bot Application", etc
> - "Macro" suffix, e.g. "JIRA Macro", etc
>
> Technically this means using the following in pom.xml:
>
> <properties>
> <!-- Name to display by the Extension Manager -->
> <xwiki.extension.name>Wiki Component API</xwiki.extension.name>
> </properties>
>
> WDYT?
>
> Thanks
> -Vincent
>
Sounds good. What about implementations, for example the portlet and
servlet containers?
Good question.
What I've done today for Extension submodule is:
<artifactId>xwiki-commons-extension-repository-xwiki</artifactId>
<name>XWiki Commons - Extension - Repository - XWiki</name>
<packaging>jar</packaging>
<description>Allows accessing extensions located in an XWiki
instance</description>
<properties>
<xwiki.jacoco.instructionRatio>0</xwiki.jacoco.instructionRatio>
<!-- Old names of this module used for retro compatibility when resolving
dependencies of old extensions -->
<xwiki.extension.features>org.xwiki.platform:xwiki-platform-extension-repository-xwiki-handler,org.xwiki.commons:xwiki-commons-extension-repository-xwiki-handler</xwiki.extension.features>
<!-- Name to display by the Extension Manager -->
<xwiki.extension.name>Repository Module - XWiki
support</xwiki.extension.name>
</properties>
So we could do the same, use something like:
"Container API - Servlet support"
"Container API - Portlet support"
OK, but maybe "support" should be replaced with something more
appropriate for each type of implementation, like "backend", or "-based
implementation".