Hello,
On Fri, Jun 24, 2011 at 9:12 PM, Sergiu Dumitriu <sergiu(a)xwiki.com> wrote:
On 06/24/2011 09:51 AM, Vincent Massol wrote:
Hi,
The proposal is to make all click methods be named click*() in UI
functional
tests.
For example in ViewPage, instead of:
public LoginPage login()
{
this.loginLink.click();
return new LoginPage();
}
We would have:
public LoginPage clickLogin()
{
this.loginLink.click();
return new LoginPage();
}
Right now we have some methods starting with click and other not
following this
pattern, the idea is to homogeneize it.
WDYT?
+1 only for when the method does nothing more than click on an element
and wait for some conditions to be met. If the method does something
else as well, then it should have a name that describes the whole
process or the end result.
I agree with Sergiu. So +1 for when the method does nothing more than click.
Raluca.
--
Sergiu Dumitriu
http://purl.org/net/sergiu/
_______________________________________________
devs mailing list
devs(a)xwiki.org
http://lists.xwiki.org/mailman/listinfo/devs